Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2026 - 18:00 AEST
Scheduled
We will be performing scheduled maintenance to roll out a major upgrade to the AUDD Digital platform. Impact
During this window, the AUDD Digital platform will be fully unavailable.
This upgrade introduces: A new platform interface Unified AUDD wallet and consolidated balances Updated account and login experience
Important Notes: All balances (including AUD) will be consolidated into a single AUDD balance New AUDD wallet addresses (across supported blockchains) will be issued Transfers to old AUDD addresses after the upgrade may not be credited Passwords and 2FA will need to be reset after the upgrade Transfers of AUDD across supported blockchains (including StellarAUDD) will continue to function as usual
Further updates will be shared here during the maintenance.
Posted Sep 09, 2026 - 17:49 AEST
This scheduled maintenance affected: AUDD Digital Platform.